AttoPilot Users Group

Smarter Cheaper Faster

Hi Guys,

Is anybody really good with Digi x-tend modems.

I have to have the baud rate set at 38400 and the over air rate at 9600 (to get more range).
I can control the rate of strings sent at 38400 (1Hz – 5Hz) but I can’t change the baud rate.
Now the problem is that the strings that come in are in blocks of 256 bytes and they are coming in at 1 Hz? They are getting chopped up info is getting lost. Do you know of a way to set up the modem so that the strings just flow in line by line? Can this be done or does the Baud rate have to match the over air baud rate. If I up the over air baud rate to 115200 it does the same thing but a lot more info gets through the problem is greatly reduced. Only trouble is I can’t leave it at 115200 because the range is greatly reduced.

Thanks in advance.

Views: 17

Reply to This

Replies to This Discussion

Hi Scott,

Have you had a fiddle with the PK and RB parameters in the Digi radios? PK sets the maximum packet size that will be sent, and this will default to 256 for an over the air bit rate of 9600. I would leave this alone in the first instance. RB is the number of characters that will accumulate before transmission commences, and is probably set to 256 with an over the air data rate of 9600.

Perhaps it would be worth trying to get transmissions away earlier by setting RB to a smaller value? Maybe try setting RB to somewhere in the range 32 - 64. Smaller values may end up being counter productive as protocol overhead eats into RF bandwidth.

Andrew.

Reply to Discussion

RSS


Locations of visitors to this page

© 2017   Created by Gary Mortimer.   Powered by

Badges  |  Report an Issue  |  Terms of Service