AttoPilot Users Group

Smarter Cheaper Faster

Has anyone attempted to put Atto on a Sig LT 40? I'd be interested in the results.


Bill Hurlock

Views: 131

Reply to This

Replies to This Discussion

Thanks for the info. I have a Dragon OSD RTL in it right now.
Chris, I should have a V2.0 atto sometime next week. Do you know of anyone who might have a config file that would get me close on a LT-40. I might also need a bit of help on interfacing this to a Spectrum DX-7. I'm running a Dragon on my LT-40 at the moment so the install shouldn't be to bad. Is there a place to get some ideas on the pito tube construction?

Chris McNair said:
Hi Chris, I now have a Atto v2.0. I need a bit of help on how to log into the atto and make changes to the program settings. I read the manual that I got with the unit but it doesn't get into how to connect to the atto with a PC. Is there another manual that explains the programing connection setup??

Chris McNair said:

Here is what I have observed about the system.

1. I have double checked all connections and I have everything connected correctly.

2. When I boot up the system, I see the Red LED light for abot 5 or so seconds and goes black for a bit and than it starts to blink the mode I'm in on the RC radio. If I change modes it blinks the number of the mode.

The GPS module itself Blinks once and goes black. After about 10 seconds or so I get the Lock blink on the GPS module. Once I see the lock I still never see the Main LED do anything other than blink the Mode Number.

3. Using Happy's GCS I start seeing all the strings being sent from his program and I start seeing Atto outbound packets . I never see Location strings with any NEMA coord info in them. Just 0,0,0,0, kind of packet strings indicating no info.

4. I am seeing Servo info OK.

5. When I get to the point where I'm seeing the Mode blink, if I try and move the sticks around on the RC radio I get very tiny movements of the Planes control surfaces. As a side note. I have done the ground cal by setting $55= 1 and moved all sticks throughtout there full range during the 10 seconds the RED LED is on. The next part where it moves for a turn and than up all work. The Cal.txt file is being written to the SD card however the low and high numbers are very close together. The solution I found to this problem was to go into config on HK's program an make a change of value to any param and write it. Once the write completes all control movements are fully implemented on stick movement in any mode. 

6. The things I don't see coming from atto to GCS are: No GPS data in the strings even with a good lock light on the GPS unit. No battery data in the strings. Good servo info in strings.

7. I disconnected the GPS from atto and connected it to my PC term program and it is outputting good NEMA strings at a baud rate of 115400. I tried making changes to the baud rate with the term program and it responds to commands OK. The reason for the color code question  on the GPS connector was I had removed the two data leads and forgot to make note of there correct locations in the GPS connector shell. Current order from Black end is Black, Red, Orange, Brown.

8. After I get the full control of surfaces, if I put the atto in ARC and hold it over head and change attitudes the control surfaces are all moving in the correct directions proportional to the the amount of tilt I put on the the plane. 

9. I have went through the config menu and made all the basic changes to the params using the default values for a start point. I input the pitot numbers from the CAL.TX file and left the other servo numbers at default values because of the closeness of the HI LO values for the moment. I checked for servo end points so I can't drive them into limits with the numbers in Config.

In summary: No gps number of sats blinks in RED LED after GPS lock just mode number blinks. I left plane outside for a complete rundown on the battery just in case it needed more time. No GPS data in any strings on HK's GCS program. No Battery data in strings. GPS into a terminal program shows Good NEMA info including my correct Lat/Lon at 115400 baud rate. Upon first boot up very limited control surface movements on all surfaces until I write any new parm into config. All surfaces after the write move in the correct directions for for full range of movements input to RC TX. Firmware ver in atto is from Dean and is V2 2_16_11.fwr. Load looked good. Fast flash for a period of time ending with a reboot and delete of the fwr file from SD card. I have done a reload just on the outside chance it was a corrupted upload to atto. Results the same good load. All notes above the same. One last note I don't have my pito tube in place yet. That was todays project. One other question and comment. This system is mounted up in a stock LT-40. Question on mount up of the 4 way Thermopile. Do they have to see out above the wing dihedral?  I have them just behind the wing


So there you have the skinny on what I see. I feel pretty comfortable with everything as I have played in the auto pilot area before. I also do a lot of this stuff in my real life job. Connect once check twice. Real careful about static discharge when handling things.

Thanks for your help.

Chris McNair said:



Please explain your symptoms in full so it is in one spot. We will work with you through all your questions to get you going.



The baud rate was something I thought was way to high. It is too late tonight but tomorrow evening I'll do a run from 19200 up. Does atto talk to the GPS to set it up each time it boots up? I can't see where anything was coming out of the TX port pin on atto toward the GPS. More to come.

Chris McNair said:

Sounds like your doing things right. See attached document for more info.


Try and drop your baud rate. Lets start with 19200 and go up from there. I wonder if your not the data stream.



Chris, Do I have the order correct on the GPS connector   Current order from Black end is Black, Red, Orange, Brown.
I tried reprogramming the GPS out baud rate to everything from 4800 to 115200. The RED LED just blinks the mode number.

Bill Hurlock said:
Chris, Do I have the order correct on the GPS connector   Current order from Black end is Black, Red, Orange, Brown.
Chris, I was thinking maybe the file I have for the atto is corrupt and causing the non communication with the GPS port and the other strange minimal control surface movement on boot up?? What do you think?

Bill Hurlock said:
Chris, Do I have the order correct on the GPS connector   Current order from Black end is Black, Red, Orange, Brown.
Chris, What is the correct way to cal the pressure setting in config when I'm at the field?

Reply to Discussion


Locations of visitors to this page

© 2017   Created by Gary Mortimer.   Powered by

Badges  |  Report an Issue  |  Terms of Service